package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)p\.(.*?)\d`)
var str = `This text appears at p.UNWANTED_TEXT72
This text appears between pp.UNWANTED_TEXT12-14`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}