$re = '/p\.(.*?)\d/m';
$str = 'This text appears at p.UNWANTED_TEXT72
This text appears between pp.UNWANTED_TEXT12-14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);