re = /p\.(.*?)\d/m
str = 'This text appears at p.UNWANTED_TEXT72
This text appears between pp.UNWANTED_TEXT12-14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end