using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?(\d+) (\d+).*Errors (\d+) (\d+).*";
string substitution = @" interface statistics\nreceived| \1\nsent | \2\nerrors | \3 \4";
string input = @"Interface Statistics Received Sent Bytes 30750280 8480324
Unicast packets 44928 43160
Non-unicast packets 0 0
Discards 0 0
Errors 0 0
Unknown protocols 0";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}