import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*?(\\d+) (\\d+).*Errors (\\d+) (\\d+).*";
final String string = "Interface Statistics Received Sent Bytes 30750280 8480324\n\n"
+ "Unicast packets 44928 43160\n\n"
+ "Non-unicast packets 0 0\n\n"
+ "Discards 0 0\n\n"
+ "Errors 0 0\n\n"
+ "Unknown protocols 0";
final String subst = " interface statistics\\nreceived| \\1\\nsent | \\2\\nerrors | \\3 \\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}