package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms).*?(\d+) (\d+).*Errors (\d+) (\d+).*`)
var str = `Interface Statistics Received Sent Bytes 30750280 8480324
Unicast packets 44928 43160
Non-unicast packets 0 0
Discards 0 0
Errors 0 0
Unknown protocols 0`
var substitution = " interface statistics\nreceived| \1\nsent | \2\nerrors | \3 \4"
fmt.Println(re.ReplaceAllString(str, substitution))
}