#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?\d{1,5}(?:\.\d{1,2})?$"
Local $sString = "-1.12" & @CRLF & _
"12345" & @CRLF & _
"1" & @CRLF & _
"123" & @CRLF & _
"12.12" & @CRLF & _
"-12345" & @CRLF & _
"-1.12" & @CRLF & _
"-" & @CRLF & _
"-1" & @CRLF & _
"-1." & @CRLF & _
"-1.1" & @CRLF & _
"-1.12" & @CRLF & _
"-12345" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-1.123" & @CRLF & _
"1234567" & @CRLF & _
"123456" & @CRLF & _
"1.1111" & @CRLF & _
"-." & @CRLF & _
"-.." & @CRLF & _
".1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")