use strict;
my $str = '-1.12
12345
1
123
12.12
-12345
-1.12
-
-1
-1.
-1.1
-1.12
-12345
-1.123
1234567
123456
1.1111
-.
-..
.1';
my $regex = qr/^-?\d{1,5}(?:\.\d{1,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}