const regex = /^-?\d{1,5}(?:\.\d{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?\\d{1,5}(?:\\.\\d{1,2})?$', 'gm')
const str = `-1.12
12345
1
123
12.12
-12345
-1.12
-
-1
-1.
-1.1
-1.12
-12345
-1.123
1234567
123456
1.1111
-.
-..
.1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}