const regex = /^(20|23|24|27|30|33|34)\d{8}\d{1}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(20|23|24|27|30|33|34)\\d{8}\\d{1}$', 'gm')
const str = `20389812277`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}