$re = '/^(20|23|24|27|30|33|34)\d{8}\d{1}$/m';
$str = '20389812277';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);