package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{3}-[a-zA-Z]{5,8}$`)
var str = `123-abcde
1234-abcde
456-product
456-product2
456-productname`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}