$re = '/^\d{3}-[a-zA-Z]{5,8}$/m';
$str = '123-abcde
1234-abcde
456-product
456-product2
456-productname';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);