re = /^\d{3}-[a-zA-Z]{5,8}$/m
str = '123-abcde
1234-abcde
456-product
456-product2
456-productname'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end