const regex = /\Qmywebsite.com\E.*?\K\d+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\Qmywebsite.com\\E.*?\\K\\d+', '')
const str = `http://www.mywebsite.com/id/37246238/page`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}