$re = '/\Qmywebsite.com\E.*?\K\d+/';
$str = 'http://www.mywebsite.com/id/37246238/page';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);