re = /\Qmywebsite.com\E.*?\K\d+/
str = 'http://www.mywebsite.com/id/37246238/page'
# Print the match result
str.match(re) do |match|
puts match.to_s
end