$re = '/(?:\G(?!\A)|\(TRACK\s+"([^"]*)"\s+([PF]))\s+(\([SP](?:[^()]*+|(?-1))*\))\)?/m';
$str = 'Some crap string here...(TRACK "title1" F (S #h88 (P #m6) (P #m31)) (S #k3 (P #m58) (P #m58)))(TRACK "title2" P (S #a54 (P #r8)) (S #v59 (P #a25) (P #y82)))...Some other crap string here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);