import re
regex = re.compile(r"(?:\G(?!\A)|\(TRACK\s+\"([^\"]*)\"\s+([PF]))\s+(\([SP](?:[^()]*+|(?-1))*\))\)?", flags=re.MULTILINE)
test_str = "Some crap string here...(TRACK \"title1\" F (S #h88 (P #m6) (P #m31)) (S #k3 (P #m58) (P #m58)))(TRACK \"title2\" P (S #a54 (P #r8)) (S #v59 (P #a25) (P #y82)))...Some other crap string here"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")