using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(set [a-zA-Z0-9]+=.* &&)+ (call set [a-zA-Z0-9]+=%[a-zA-Z0-9%]+%).* call %.*%";
string input = @"set env1=ec && set env2=ho && call set env3=%env1% %env2% && call %env3%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}