package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(set [a-zA-Z0-9]+=.* &&)+ (call set [a-zA-Z0-9]+=%[a-zA-Z0-9%]+%).* call %.*%`)
var str = `set env1=ec && set env2=ho && call set env3=%env1% %env2% && call %env3%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}