re = /(set [a-zA-Z0-9]+=.* &&)+ (call set [a-zA-Z0-9]+=%[a-zA-Z0-9%]+%).* call %.*%/m
str = 'set env1=ec && set env2=ho && call set env3=%env1% %env2% && call %env3%'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end