#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^:\/?#]+:)?(?:(?:\/\/)?(?:[^\s\/?#]+\.)+[^\s\/?#]+(?:\/[^\s"#]*)?)$"
Local $sString = "xn--4gbrim.xn--wgbh1c" & @CRLF & _
"中文域名.中国" & @CRLF & _
"😄❤️🌟.ws" & @CRLF & _
"example.com" & @CRLF & _
"xn--mgbah1a3hjkrd.com" & @CRLF & _
"🍕🏞️🎵.online" & @CRLF & _
"技术论坛.中国" & @CRLF & _
"www.nck.gg" & @CRLF & _
"www.www2.test.com" & @CRLF & _
"xn--80aaag1a8aj.xn" & @CRLF & _
"商业网站.中国"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")