$re = '/^(?:[^:\/?#]+:)?(?:(?:\/\/)?(?:[^\s\/?#]+\.)+[^\s\/?#]+(?:\/[^\s"#]*)?)$/m';
$str = 'xn--4gbrim.xn--wgbh1c
中文域名.中国
😄❤️🌟.ws
example.com
xn--mgbah1a3hjkrd.com
🍕🏞️🎵.online
技术论坛.中国
www.nck.gg
www.www2.test.com
xn--80aaag1a8aj.xn
商业网站.中国';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);