#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-z]+\.?[a-z]?)*[a-z]+$"
Local $sString = "hi.man" & @CRLF & _
"hi.man.hi.man" & @CRLF & _
"hiMan" & @CRLF & _
"hi, man." & @CRLF & _
"hi, man 12" & @CRLF & _
"hi, man 1.2" & @CRLF & _
"hi man" & @CRLF & _
"hi,man" & @CRLF & _
"hd.dh.h" & @CRLF & _
"das..dsa" & @CRLF & _
"d.d.d" & @CRLF & _
"dd.ddd.d..d" & @CRLF & _
"d.d.dddas."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")