re = /^([a-z]+\.?[a-z]?)*[a-z]+$/mi
str = 'hi.man
hi.man.hi.man
hiMan
hi, man.
hi, man 12
hi, man 1.2
hi man
hi,man
hd.dh.h
das..dsa
d.d.d
dd.ddd.d..d
d.d.dddas.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end