package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([a-z]+\.?[a-z]?)*[a-z]+$`)
var str = `hi.man
hi.man.hi.man
hiMan
hi, man.
hi, man 12
hi, man 1.2
hi man
hi,man
hd.dh.h
das..dsa
d.d.d
dd.ddd.d..d
d.d.dddas.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}