#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<lat0>\d+)[-|\s](?<lat1>\d+)[.|,|\s](?<lat2>\d+)['|\s]?(?<latDir>[N|n|S|s])[,|\s|\-|–]+(?<lon0>\d+)[-|\s](?<lon1>\d+)[.|,|\s](?<lon2>\d+)['|\s]?(?<lonDir>[E|e|W|w])"
Local $sString = "48-22.676N, 004-27.209W" & @CRLF & _
"47-14.13'N, 002-16.32'W" & @CRLF & _
"48 45,852N - 003 07,217W" & @CRLF & _
"44-39.95'N, 001-09.95'W" & @CRLF & _
"45-54.35n, 001-19.37w" & @CRLF & _
"47-38.542N - 003-14.699W" & @CRLF & _
"47-34.39 N – 002-52.41W" & @CRLF & _
"47 53 823 N – 3 58 538 W"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")