use strict;
my $str = '48-22.676N, 004-27.209W
47-14.13\'N, 002-16.32\'W
48 45,852N - 003 07,217W
44-39.95\'N, 001-09.95\'W
45-54.35n, 001-19.37w
47-38.542N - 003-14.699W
47-34.39 N – 002-52.41W
47 53 823 N – 3 58 538 W';
my $regex = qr/(?<lat0>\d+)[-|\s](?<lat1>\d+)[.|,|\s](?<lat2>\d+)['|\s]?(?<latDir>[N|n|S|s])[,|\s|\-|–]+(?<lon0>\d+)[-|\s](?<lon1>\d+)[.|,|\s](?<lon2>\d+)['|\s]?(?<lonDir>[E|e|W|w])/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}