# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<lat0>\d+)[-|\s](?<lat1>\d+)[.|,|\s](?<lat2>\d+)['|\s]?(?<latDir>[N|n|S|s])[,|\s|\-|–]+(?<lon0>\d+)[-|\s](?<lon1>\d+)[.|,|\s](?<lon2>\d+)['|\s]?(?<lonDir>[E|e|W|w])"
test_str = ("48-22.676N, 004-27.209W\n"
"47-14.13'N, 002-16.32'W\n"
"48 45,852N - 003 07,217W\n"
"44-39.95'N, 001-09.95'W\n"
"45-54.35n, 001-19.37w\n"
"47-38.542N - 003-14.699W\n"
"47-34.39 N – 002-52.41W\n"
"47 53 823 N – 3 58 538 W")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.