#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)~ ?([\w\*\-\+\/ ]+)(!r)?"
Local $sString = "a ~ b c d*e !r x" & @CRLF & _
"a ~ b c" & @CRLF & _
"a ~ b c d1 !r y," & @CRLF & _
"a ~ b c D !r z," & @CRLF & _
"a~b c d*e!r z"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")