using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~ ?([\w\*\-\+\/ ]+)(!r)?";
string input = @"a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y,
a ~ b c D !r z,
a~b c d*e!r z";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}