$re = '/~ ?([\w\*\-\+\/ ]+)(!r)?/m';
$str = 'a ~ b c d*e !r x
a ~ b c
a ~ b c d1 !r y,
a ~ b c D !r z,
a~b c d*e!r z';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);