#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[a-zа-яёіїє0-9][a-zа-яёіїє0-9'-_]+[a-zа-яёіїє0-9]|[a-zа-яёіїє0-9]+"
Local $sString = "asdf a as" & @CRLF & _
"asdf, asdf asdf ,asdf asdf , asdf" & @CRLF & _
",,, asdf asdfasdf,asdf" & @CRLF & _
"(asdfasdf)" & @CRLF & _
"456456 1 12" & @CRLF & _
"фываФЫВА" & @CRLF & _
"фываё" & @CRLF & _
"фіва - фівафві" & @CRLF & _
"фвіа фівоажлдіва" & @CRLF & _
"ііфваів'фіваів 'h'a'a'a' ' asdf' 'asdf" & @CRLF & _
"ііфваів-фіваів -a-a-a-a- - asdf- -asdf" & @CRLF & _
"jkjkhljkh_hj _B_B_B_B_B_B_ _ hjkl_ _hjhjl" & @CRLF & _
"8885 4566" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")