// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)[a-zа-яёіїє0-9][a-zа-яёіїє0-9'-_]+[a-zа-яёіїє0-9]|[a-zа-яёіїє0-9]+").unwrap();
let string = "asdf a as
asdf, asdf asdf ,asdf asdf , asdf
,,, asdf asdfasdf,asdf
(asdfasdf)
456456 1 12
фываФЫВА
фываё
фіва - фівафві
фвіа фівоажлдіва
ііфваів'фіваів 'h'a'a'a' ' asdf' 'asdf
ііфваів-фіваів -a-a-a-a- - asdf- -asdf
jkjkhljkh_hj _B_B_B_B_B_B_ _ hjkl_ _hjhjl
8885 4566
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}