$re = '/[a-zа-яёіїє0-9][a-zа-яёіїє0-9\'-_]+[a-zа-яёіїє0-9]|[a-zа-яёіїє0-9]+/i';
$str = 'asdf a as
asdf, asdf asdf ,asdf asdf , asdf
,,, asdf asdfasdf,asdf
(asdfasdf)
456456 1 12
фываФЫВА
фываё
фіва - фівафві
фвіа фівоажлдіва
ііфваів\'фіваів \'h\'a\'a\'a\' \' asdf\' \'asdf
ііфваів-фіваів -a-a-a-a- - asdf- -asdf
jkjkhljkh_hj _B_B_B_B_B_B_ _ hjkl_ _hjhjl
8885 4566
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);