package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:|\|^)([^|]{3,})(?:|$|\n)`)
var str = `test test| teste test test3 | test test 4|efd|df|
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}