re = /(?:|\|^)([^|]{3,})(?:|$|\n)/m
str = 'test test| teste test test3 | test test 4|efd|df|
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end