$re = '/(?:|\|^)([^|]{3,})(?:|$|\n)/m';
$str = 'test test| teste test test3 | test test 4|efd|df|
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);