import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[\\S]+received_bytes_count )(?:true|false) ([\\S]+)|(?:[\\S]+received_bytes_count )([\\S]+) (?:true|false)|(?:[\\S]+received_bytes_count )([\\S]+)";
final String string = "compute.googleapis.com/instance/network/received_bytes_count fleetwood false\n"
+ "compute.googleapis.com/instance/network/received_bytes_count false graceland\n"
+ "compute.googleapis.com/instance/network/received_bytes_count false creedence\n"
+ "compute.googleapis.com/instance/network/received_bytes_count false gke-oamstest-default-pool-bcb12758-nvb9\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-nvb9 true\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-6bzw false\n"
+ "compute.googleapis.com/instance/network/received_bytes_count true gke-oamstest-default-pool-bcb12758-6bzw\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-s4td false\n"
+ "compute.googleapis.com/instance/network/received_bytes_count true gke-oamstest-default-pool-bcb12758-s4td\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-nvb9\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-6bzw\n"
+ "compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-s4td\n";
final String subst = "$1$2$3 Rcvd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}