import re
regex = re.compile(r"(?:[\S]+received_bytes_count )(?:true|false) ([\S]+)|(?:[\S]+received_bytes_count )([\S]+) (?:true|false)|(?:[\S]+received_bytes_count )([\S]+)")
test_str = ("compute.googleapis.com/instance/network/received_bytes_count fleetwood false\n"
"compute.googleapis.com/instance/network/received_bytes_count false graceland\n"
"compute.googleapis.com/instance/network/received_bytes_count false creedence\n"
"compute.googleapis.com/instance/network/received_bytes_count false gke-oamstest-default-pool-bcb12758-nvb9\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-nvb9 true\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-6bzw false\n"
"compute.googleapis.com/instance/network/received_bytes_count true gke-oamstest-default-pool-bcb12758-6bzw\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-s4td false\n"
"compute.googleapis.com/instance/network/received_bytes_count true gke-oamstest-default-pool-bcb12758-s4td\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-nvb9\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-6bzw\n"
"compute.googleapis.com/instance/network/received_bytes_count gke-oamstest-default-pool-bcb12758-s4td\n")
subst = "$1$2$3 Rcvd"
result = regex.sub(subst, test_str)
if result:
print(result)