#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:OTC|CH)_.*[0-9]{8}\.csv$"
Local $sString = "OTC_omega_20210302.csv" & @CRLF & _
"CH_delta_20210302.csv" & @CRLF & _
"MD_omega_20210310.csv" & @CRLF & _
"CD_delta_20210310.csv"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")