const regex = /^(?:OTC|CH)_.*[0-9]{8}\.csv$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:OTC|CH)_.*[0-9]{8}\\.csv$', 'gm')
const str = `OTC_omega_20210302.csv
CH_delta_20210302.csv
MD_omega_20210310.csv
CD_delta_20210310.csv`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}