import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:OTC|CH)_.*[0-9]{8}\\.csv$";
final String string = "OTC_omega_20210302.csv\n"
+ "CH_delta_20210302.csv\n"
+ "MD_omega_20210310.csv\n"
+ "CD_delta_20210310.csv";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}