import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<unit_type>SFA)(?P<unit_size>80|63|50|40|32|25)(?P<mounting_type>G|F)(?P<tank_port>T|)(?P<decompression_feature>0|1)(?P<sep_1>-)(?P<unit_series>1X)(?P<sep_2>/)(?P<seal_material>M)(?P<sep_3>/)(?P<pipe_port>01)(?P<additional_details>(.|[0-9])*)$\n";
final String string = "SFA80F1-1X/M/01\n"
+ "SFA80F0-1X/M/01\n"
+ "SFA32G0-1X/M/01\n"
+ "SFA32GT0-1X/M/01\n"
+ "SFA32G1-1X/M/01\n"
+ "SFA40FT0-1X/M/01\n"
+ "SFA40F0-1X/M/01\n"
+ "SFA40F1-1X/M/01\n"
+ "SFA50F1-1X/M/01\n"
+ "SFA50F0-1X/M/01\n"
+ "SFA50FT0-1X/M/01\n"
+ "SFA63F0-1X/M/01\n"
+ "SFA63F1-1X/M/01\n"
+ "SFA63FT0-1X/M/01\n"
+ "SFA25G0-1X/M/01\n"
+ "SFA80FT1-1X/M/01\n"
+ "SFA80FT0-1X/M/01\n"
+ "SFA32GT1-1X/M/01\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}