using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\((?:[^\(\)]*\g<0>*)*\))";
string input = @"1+(x*(3-4)+5)-1(g*(h)()(()))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}