$re = '/(\((?:[^\(\)]*\g<0>*)*\))/';
$str = '1+(x*(3-4)+5)-1(g*(h)()(()))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);