package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\((?:[^\(\)]*\g<0>*)*\))`)
var str = `1+(x*(3-4)+5)-1(g*(h)()(()))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}