using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*_Page)\d+$(?!\r?\n\1\d+$)";
string input = @"A_File1_Page1
A_File1_Page2
A_File2_Page1
A_File2_Page2
A_File2_Page3
B_File1_Page1
B_File1_Page2
B_File1_Page3
B_File2_Page1
B_File2_Page2
B_File2_Page3
B_File2_Page4
C_File1_Page1
C_File1_Page2
C_File1_Page3
C_File1_Page4
C_File1_Page5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}