# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*_Page)\d+$(?!\r?\n\1\d+$)"
test_str = ("A_File1_Page1\n"
"A_File1_Page2\n\n"
"A_File2_Page1\n"
"A_File2_Page2\n"
"A_File2_Page3\n\n"
"B_File1_Page1\n"
"B_File1_Page2\n"
"B_File1_Page3\n\n"
"B_File2_Page1\n"
"B_File2_Page2\n"
"B_File2_Page3\n"
"B_File2_Page4\n\n"
"C_File1_Page1\n"
"C_File1_Page2\n"
"C_File1_Page3\n"
"C_File1_Page4\n"
"C_File1_Page5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.